Errore di aggiornamento del componente aggiuntivo in Copilot per il componente aggiuntivo Sales per Microsoft Outlook

Questo articolo consente di risolvere e risolvere un messaggio di errore che richiede ripetutamente agli utenti di aggiornare il componente aggiuntivo Microsoft Copilot for Sales per Outlook.

Nota

Microsoft Sales Copilot viene rinominato Come Microsoft Copilot for Sales nel gennaio 2024. Gli screenshot in questo articolo verranno aggiornati presto con il nuovo nome.

Chi è interessato?

Tipo di requisito Description
App client Componente aggiuntivo Copilot for Sales Outlook
Piattaforma Client Web e desktop
Sistema operativo Windows e Mac
Distribuzione Gestita dall'utente e gestita dall'amministratore
CRM Dynamics 365 e Salesforce
Utenti Tutti gli utenti

Sintomi

Quando si apre il riquadro Copilot for Sales in Microsoft Outlook, viene visualizzato il seguente messaggio di errore:

Errore del componente aggiuntivo: è disponibile un aggiornamento di questo componente aggiuntivo che richiede la revisione e la conferma per l'installazione.

Quando si seleziona AGGIORNA, il comportamento dipende dal fatto che si usi Outlook sul web o l'app desktop.

Screenshot che mostra l'errore di aggiornamento del componente aggiuntivo e il pulsante UPDATE.

  • Se si usa Outlook sul web, viene avviata una nuova finestra del browser e si passa alla schermata Copilot for Sales for Microsoft Outlook nella finestra popup Componenti aggiuntivi per Outlook. Il messaggio di errore viene ancora visualizzato nella nuova finestra del browser. Tuttavia, nella finestra del browser originale è possibile usare temporaneamente Copilot for Sales finché la pagina non viene aggiornata e viene visualizzato il messaggio di errore originale.

  • Se utilizzi l'app desktop Outlook, viene visualizzato un successivo messaggio di errore che indica che il componente aggiuntivo è attualmente in fase di aggiornamento. Quando si chiude il riquadro Copilot for Sales e lo si riapre, Copilot for Sales funziona temporaneamente fino a quando non si chiude o si riapre Outlook e si ripete l'errore.

    Screenshot che mostra l'avviso del componente aggiuntivo nell'app desktop di Outlook.

Causa

Le modifiche alle autorizzazioni SONO state apportate nel nuovo componente aggiuntivo Copilot for Sales per Outlook.

Alcune modifiche alle autorizzazioni richiedono il consenso esplicito dell'amministratore o la reinstallazione del componente aggiuntivo Copilot for Sales Outlook. Queste modifiche alle autorizzazioni sono sempre associate a un aggiornamento recente del componente aggiuntivo Copilot for Sales Outlook. È possibile verificare quando l'ultimo aggiornamento è stato applicato al componente aggiuntivo nella Pagina dei dettagli dell'origine dell'app corrispondente. Se viene visualizzato un aggiornamento recente del componente aggiuntivo Copilot for Sales Outlook, è probabile che l'errore sia associato alle modifiche di autorizzazione corrispondenti a causa dell'aggiornamento.

Risoluzione

Il primo passaggio consiste nell'identificare se il componente aggiuntivo Copilot for Sales Outlook è gestito dall'amministratore o gestito dall'utente. Puoi eseguire i passaggi di risoluzione di conseguenza.

  1. Apri Outlook (web o desktop).

  2. Selezione Ottieni componenti aggiuntivi nella scheda Home della barra multifunzione.

  3. Nella finestra Componenti aggiuntivi per Outlook controllare se il componente aggiuntivo Copilot for Sales for Microsoft Outlook è elencato nella sezione Gestita dall'amministratore.

    Screenshot che mostra la sezione Gestita dall'amministratore in cui è possibile verificare se è elencato il componente aggiuntivo Copilot for Sales for Microsoft Outlook.

  4. Se il componente aggiuntivo è elencato nella sezione Gestito dall'amministratore, chiedere all'amministratore tenant di eseguire questi passaggi:

    1. Nell'interfaccia di amministrazione di Microsoft 365, seleziona Impostazioni>App integrate.

    2. Nella pagina App integrate selezionare l'app Copilot for Sales.

      Verrà visualizzato il pannello Microsoft Copilot for Sales .

    3. Se il pulsante Aggiorna è disponibile, selezionarlo e seguire le istruzioni per aggiornare il componente aggiuntivo.

    4. Se il pulsante Aggiorna non è disponibile, passare alla scheda Configurazione , selezionare Copilot for Sales for Microsoft Outlook e quindi selezionare Rimuovi. Al termine, reinstallare il componente aggiuntivo Copilot for Sales per Microsoft Outlook. Per altre informazioni, vedere Installare Copilot for Sales.

  5. Se il componente aggiuntivo non è elencato nella sezione Gestito dall'amministratore, disinstalla il componente aggiuntivo da Miei componenti aggiuntivi e reinstallalo.

Nota

Possono essere necessarie fino a 24 ore prima che le modifiche siano effettive per gli utenti finali quando vengono distribuite tramite il flusso gestito dall'amministratore.

Ulteriori informazioni

Se il problema non è ancora risolto, passare a Copilot for Sales - Microsoft Community Hub per coinvolgere gli esperti.