예측 관련 문제 해결

이 문서는 Microsoft Dynamics 365 Sales 예측과 관련된 문제를 해결하고 resolve 데 도움이 됩니다.

문제 1 - 지역 기반 예측을 만들려고 할 때 오류가 표시됩니다.

증상

지역 기반 예측을 만들려고 하면 오류가 표시됩니다. 또한 지역 기반 예측의 데이터는 새로 고쳐지지 않을 수 있습니다.

원인

시스템 업데이트가 수행되면 지역 엔터티의 계층 구조가 비활성화됩니다(이전에 사용하도록 설정했음에도 불구하고). 이로 인해 이 오류가 발생합니다.

해결 방법

이 문제를 resolve 관계에서 territory_parent_territory 관계 정의에서 계층 구조를 사용하도록 설정해야 합니다. 다음 단계를 따릅니다.

  1. 고급 설정으로 이동합니다.

    탭에서 사전 설정 페이지가 열립니다.

  2. 설정>사용자 지정>사용자 지정을 선택합니다.

    Power Apps 설정 페이지가 열립니다.

  3. 데이터>엔터티를 선택한 다음, Territory를 선택합니다.

    Power Apps에서 지역 엔터티를 선택합니다.

  4. 지역 페이지에서 관계 탭을 선택한 다음, 부모를 선택합니다.

    영역 엔터티에 대한 부모를 선택합니다.

  5. 다대일 대화 상자에서 계층적 검사 상자를 선택한 다음 완료를 선택합니다.

    다대일 대화 상자에서 계층 옵션을 사용하도록 설정합니다.

  6. 엔터티를 저장하고 닫습니다.

문제 2 - 기회 양식에서 예측 범주 필드를 숨길 수 없습니다.

원인

경우에 따라 앱은 양식 사용자 지정을 통해 기본적으로 보이지 않는 것으로 구성된 후에도 예측 범주 필드를 기회 형식으로 표시합니다.

해결 방법

이 오류를 resolve 양식에서 예측 범주 필드를 삭제해야 합니다. 다음 단계를 따릅니다.

  1. 앱의 탐색 모음에서 설정 아이콘을 선택한 다음 고급 설정을 선택합니다.

    설정 메뉴의 고급 설정입니다.

    새 브라우저 탭에서 비즈니스 관리 설정 페이지가 열립니다.

  2. 탐색 모음에서 설정을 선택한 다음 사용자 지정에서 사용자 지정을 선택합니다.

  3. 시스템 사용자 지정을 선택합니다.

  4. 솔루션 탐색기의 구성 요소 아래에서 엔터티를 확장하고 영업 기회를 확장한 다음 양식을 선택합니다.

  5. 기본 형식 양식의 기회 양식을 엽니다.

    기회 양식이 새 창에서 열립니다.

  6. 요약 섹션에서 예측 범주 필드를 선택한 다음 제거를 선택합니다.

    예측 범주 필드를 제거합니다.

  7. 구성을 저장하고 게시합니다.

문제 3 - 예측을 볼 수 없습니다.

원인

이전 버전의 예측을 사용하고 최신으로 업데이트한 경우 예측 사이트 맵이 업데이트되지 않을 수 있습니다. 이는 예측 사이트 맵이 이전 버전의 예측을 열 수 있도록 하는 Sales Hub 앱의 관리되지 않는 계층이 존재하기 때문에 발생할 수 있습니다.

다음 이미지는 이전 버전의 예측 홈페이지의 예입니다.

이전 버전의 예측 홈페이지입니다.

해결 방법

이 문제를 resolve 예측 사이트 맵 항목을 최신 예측 항목 표로 업데이트합니다. 자세한 내용은 사이트 맵에서 예측 그리드 및 구성 옵션 추가를 참조하세요.

문제 4 - 예측 그리드를 로드할 수 없고 오류가 표시됩니다.

원인

ForecastInstanceActions 프로세스가 비활성화됩니다. 그 이유는 organization 소유자가 변경되어 예측 그리드를 로드하지 못하기 때문일 수 있습니다. 다음 이미지에 표시된 오류가 표시됩니다.

예측을 가져오기 위한 작업(ForecastInstanceActions)이 비활성화되었습니다.

예측을 가져오기 위한 오류 메시지 작업(ForecastInstanceAction)이 비활성화되었습니다.

해결 방법

이 오류를 resolve 하려면 ForecastInstanceActions 프로세스를 활성화합니다. 다음 단계를 따릅니다.

  1. 고급 설정으로 이동한 다음 설정>프로세스 센터>프로세스를 선택합니다.

  2. 검색 상자에 ForecastInstanceActions를 입력합니다. 프로세스가 초안 상태임을 확인할 수 있습니다.

    ForecastInstanceActions는 초안 상태의 프로세스입니다.

  3. 프로세스를 선택한 다음 활성화를 선택합니다.

    ForecastInstanceActions 프로세스를 활성화합니다.

  4. 확인 메시지에서 활성화를 선택합니다.

    instance 작업 프로세스가 활성화됨을 예측합니다.

  5. 프로세스 상태가 활성화되었는지 확인한 다음 설정을 닫습니다.

문제 5 - 예측 그리드에서 드릴다운 데이터를 볼 수 없습니다.

원인

예측 구성 엔터티가 예측 그리드에서 드릴다운 데이터를 볼 수 있는 충분한 권한이 없습니다. 다음 이미지에 표시된 오류가 표시됩니다.

문제가 발생했습니다.
예측 레코드를 검색하는 동안 오류가 발생했습니다.
브라우저 페이지를 다시 로드하세요.

예측 그리드에서 드릴다운 데이터를 보려고 할 때 발생하는 오류 메시지가 잘못되었습니다.

해결 방법

이 오류를 resolve 관리자가 Forecast Configuration 엔터티에 대한 읽기 권한을 보안 역할에 제공해야 합니다. 다음 단계를 따릅니다.

  1. 고급 설정으로 이동한 다음 설정>보안>보안 역할을 선택합니다.

  2. 권한을 적용할 보안 역할을 선택합니다.

  3. 보안 역할 페이지에서 사용자 지정 엔터티 탭을 선택하고 예측 구성 행으로 이동합니다.

  4. 읽기 권한을 선택하고 제공합니다.

    예측 구성 엔터티에 대한 읽기 권한을 제공합니다.

  5. 설정을 닫습니다.

문제 6 - 예측 범주 필드가 업데이트되지 않음

원인

예측에서 예측 범주 필드를 또는 손실로 업데이트한 후에도 기회는 여전히 이전 파이프라인 버킷에 표시됩니다. 이 오류는 organization 기회 예측 범주 매핑 프로세스 워크플로가 비활성화되어 있기 때문에 발생합니다.

해결 방법

오류를 resolve 기회 예측 범주 매핑 프로세스 워크플로를 활성화합니다. 다음 단계를 따릅니다.

  1. 고급 설정으로 이동한 다음 설정사용자 지정>시스템 사용자 지정을선택합니다>.

  2. 사이트맵에서 프로세스를 선택합니다.

  3. 기회 예측 범주 매핑 프로세스 워크플로를 선택한 다음 활성화를 선택합니다.

    기회 예측 범주 매핑 프로세스 워크플로를 활성화합니다.

    기회의 예측 범주가 제대로 업데이트됩니다. 워크플로를 활성화하기 전에 변경된 기회는 수동으로 변경해야 합니다. 또한 기회 예측 범주 매핑 프로세스 워크플로를 열고 각 예측 범주에 대해 조건이 올바르게 정의되었는지 확인합니다.

    기회 예측 범주 매핑 프로세스 워크플로 조건입니다.

  4. 설정을 저장하고 닫습니다.

원인

이 문제는 "Dynamics 365 Sales 예측" 사용자에게 계층 구조 관련 조회 엔터티에 대한 읽기 권한이 없기 때문에 발생합니다.

해결 방법

이 문제를 해결하려면 다음 단계를 수행합니다.

  1. 고급 설정으로 이동하고 설정>시스템>보안 보안>역할을 선택합니다.

  2. 예측 AppUser 역할을 열고 엔터티 형식이 있는 탭을 선택합니다.

    예측 앱 사용자 역할을 보여 주는 스크린샷.

  3. 조회 필드의 엔터티 형식에 대해 organization 수준에서 읽기 권한을 사용하도록 설정합니다.

  4. 변경 내용을 저장합니다.

문제 8 - 예측을 활성화할 수 없습니다.

원인

여러 가지 이유로 인해 예측 활성화가 실패합니다.

해결 방법

이 문제를 해결하려면 다음 단계를 수행합니다.

  1. 예측 모델에 대한 모든 필수 구성을 완료했는지 확인합니다.
  2. 예측 구성의 계층 필터가 전체 계층 구조를 필터링하지 않는지 확인합니다. 일반 단계의 미리 보기 섹션으로 이동하여 계층이 있는지 확인합니다. 자세한 내용은 예측에 필터 추가를 참조하세요.

문제 9 - 앱 설정에서 예측 구성 옵션을 찾을 수 없습니다.

원인

다음과 같은 이유로 Sales Hub 앱의 앱 설정에 예측 구성 옵션이 표시되지 않을 수 있습니다.

  • 예측 구성 엔터티에 대한 읽기 권한이 없습니다.
  • 관리자가 성능 관리 섹션에서 예측 그리드 및 구성을 수동으로 추가하지 않았습니다.

해결 방법

이 문제를 해결하려면 다음 단계를 수행합니다.

  1. 예측 구성을 만들고 관리할 수 있어야 하는 사용자에게 Forecast Manager 보안 역할을 할당합니다.
  2. 예측 구성에서 예측 탐색 창 항목을 사용자 지정 앱에 추가해야 합니다.

문제 10 - 사용자 계층 구조에 대한 예측을 볼 수 없습니다.

원인

이 문제는 예측을 볼 수 있는 권한이 부족하여 발생합니다.

해결 방법

이 문제를 해결하려면 다음을 확인합니다.

  1. 다음 조건 중 하나가 충족됩니다.

    • 당신은 예측의 소유자입니다. 예측 구성의 사용 권한 단계의 소유자 조회 필드에는 소유자가 누구인지 표시됩니다.

      예측 구성의 사용 권한 단계를 보여 주는 스크린샷

    • 예측 구성의 사용 권한 단계에서 구성 한 대로 읽기 권한이 있는 보안 역할의 일부입니다.

    • 누군가가 당신과 함께 예측을 공유했습니다. 자세한 내용은 예측 공유 사용 또는 사용 안 함을 참조하세요.

  2. 예측 구성의 사용 권한 단계에서 소유자 조회 필드없음으로 설정되지 않았습니다. 없음으로 설정된 경우 아무도 예측을 볼 수 없습니다.

문제 11 - 예측 필드 값이 예측 그리드에 0 또는 비어 있음 표시

원인

선택기, 양 필드날짜 필드와 연결된 열에 필드 수준 보안이 활성화되어 있을 수 있습니다.

해결 방법

이 문제를 해결하려면 필드 보안 프로필에서 # Dynamics 365 Sales 예측 사용자에게 읽기 권한을 부여해야 합니다. 그렇지 않으면 열에 모든 사용자에게 0 이 표시됩니다. 다음 단계에 따라 필드 보안 프로필을 구성합니다.

  1. 설정>고급 설정>보안>필드 보안 프로필로 이동합니다.
  2. 0이 표시된 필드와 연결된 필드 보안 프로필을 선택합니다.
  3. 사용자추가> 선택합니다.
  4. # Dynamics 365 Sales 예측 사용자를 검색하고, 사용자 이름에 대한 확인란을 선택한 다음,추가선택을 선택합니다>.
  5. 필드 권한을 선택하고 필드에 읽기 권한을 부여합니다.
  6. 프로필을 저장하고 닫습니다.

예측을 다시 계산하고 열에 적절한 값이 표시되는지 확인합니다.

문제 12 - 예측 페이지에서 예측 열을 수동으로 다시 계산할 수 없음

원인

예측 페이지의 예측 열 수동으로 다시 계산할 수 없습니다.

해결 방법

예측의 예측 열은 7일마다 자동으로 다시 계산되며 수동 다시 계산을 지원하지 않습니다. 예측은 기록 데이터와 오픈 세일즈 파이프라인을 살펴보고 향후 수익 결과를 예측하는 AI 기반 모델을 기반으로 하기 때문입니다. 예측 열은 기회의 상태 필드를 기반으로 각 판매자 및 관리자에 대한 예상 수익을 보여 옵니다. 예측의 정확도를 최적화하려면 예측 범주 값이 상태 필드와 동기화되어 있는지 확인합니다. 기본 제공 예측 범주의 경우 워크플로는 영업 기회를 또는 손실로 닫을 때 예측 범주가 적절한 값으로 업데이트되도록 합니다.

문제 13 - 페이지가 로드되는 경우 기본 그리드 보기가 비활성화됨(읽기 전용) 예측

원인

예측 구성에 구성된 사용자 지정 JavaScript는 그리드를 편집할 수 없게 합니다.

해결 방법

이 문제를 해결하려면 사용자 지정 JavaScript 코드를 검토하고 기본 레코드 그리드 보기를 사용하지 않도록 설정하는 경우 검사.