将应用数据导出到动态工作表后,“全部刷新”不起作用

症状

使用 “导出到 Excel” 命令将应用数据导出到动态工作表。 然后,通过选择“全部数据刷新”打开下载的文件并刷新数据>。 在这种情况下,你会发现数据消失,工作簿显示为空白。 你可能会收到以下错误消息:

此 Web 查询未返回任何数据。 若要更改查询,请单击“确定”,单击编辑栏中名称框上的箭头,单击 Web 查询的外部数据范围的名称,右键单击所选内容,然后单击“编辑查询”。

显示 Web 查询在刷新导出的应用数据后未返回任何数据错误的屏幕截图。

原因

如果访问的数据受密码保护,并且 Excel 文件无法向外部数据源提交密码,则会出现此问题。

解决方案

若要解决此问题,必须编辑并保存 Web 查询。

  1. 在 Excel 文件中,选择“数据>查询 & Connections”。

    显示“数据”选项卡中的“查询和Connections”选项的屏幕截图。

  2. 查询 & Connections”窗格将在窗口右侧打开。 在“Connections”选项卡上,右键单击查询,然后选择“属性”。

    显示“查询和Connections”窗格中查询的属性设置的屏幕截图。

  3. 连接属性” 窗口随即打开。 在“ 定义 ”选项卡上,选择“ 编辑查询”。

    显示“连接”属性窗口中的“编辑查询”按钮的屏幕截图。

  4. 如果出现提示,请输入用户名和密码。 输入用于登录应用的相同用户和密码。

  5. “编辑 Web 查询 ”窗口中,选择“ 转到”。 出现错误消息:

    无法完成此操作

    显示“编辑 Web 查询”窗口中的“转到”按钮的屏幕截图。

  6. 关闭 “编辑 Web 查询 ”窗口。

  7. 这应该可以解决此问题。 通过选择“数据刷新全部”>再次刷新工作表中的数据。

    显示如何在 Excel 中刷新应用数据的屏幕截图。

如果上述步骤无法解决问题,请按照以下附加步骤操作:

  1. “编辑 Web 查询”窗口的地址栏中输入以下链接,以访问 Microsoft Dynamics 365 Customer Engagement 中的“高级设置”页。 请记住将 替换为 OrgURL 组织 URL。

    https://OrgURL/main.aspx?settingsonly=true

  2. 使用右上角的配置文件选项链接注销,然后使用正确的标识重新登录。

  3. 登录后,关闭 “编辑 Web 查询 ”窗口,然后在 Excel 文件中,选择“ 数据>刷新全部”。 数据将按预期刷新。

另请参阅

将数据导出到 Excel 动态工作表